summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2025-04-02 09:38:22 -0400
committerIan Moffett <ian@osmora.org>2025-04-02 09:38:22 -0400
commit753666a333bb9ff0b8410cd729b9d06df85e0013 (patch)
tree169aa8b4307c65430e0da1b062cce858cfc2d7e7 /configure.ac
parentd81f6b1d2cfcae0f90f2394b44cbdf03dcc0c69b (diff)
kernel/aarch64: Add initial AARCH64 portaarch64
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac36
1 files changed, 33 insertions, 3 deletions
diff --git a/configure.ac b/configure.ac
index 08cf4dd..18398a4 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,13 @@
-AC_INIT([Hyra], [1.5], [ian@osmora.org])
+AC_INIT([Hyra], [1.6], [ian@osmora.org])
+
+TARGET="amd64"
+BOOT_FW="BOOTX64.EFI"
+AC_ARG_ENABLE([aarch64],
+ [AS_HELP_STRING([--enable-aarch64], [Enable AARCH64 Support])],
+ [TARGET="aarch64"],
+ []
+)
+
KERN_CFLAGS_AMD64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector -fno-pic \\
-Werror=implicit -Werror=implicit-function-declaration \\
@@ -10,20 +19,41 @@ KERN_CFLAGS_AMD64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector
-I sys/include/ -I sys/include/lib/ -D_KERNEL -Wno-pointer-sign -MMD \\
-Wno-gnu-zero-variadic-macro-arguments -Wno-language-extension-token -Wno-tautological-constant-out-of-range-compare -Wno-c23-extensions"
+
+KERN_CFLAGS_AARCH64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector -fno-pic \\
+ -Werror=implicit -Werror=implicit-function-declaration \\
+ -Werror=implicit-int -Werror=int-conversion \\
+ -Werror=missing-prototypes \\
+ -Werror=incompatible-pointer-types -Werror=int-to-pointer-cast \\
+ -Werror=return-type -Wunused -pedantic \\
+ -I sys/include/ -I sys/include/lib/ -D_KERNEL -Wno-pointer-sign -MMD \\
+ -Wno-gnu-zero-variadic-macro-arguments -Wno-language-extension-token -Wno-tautological-constant-out-of-range-compare -Wno-c23-extensions"
+
+
QEMU_FLAGS_AMD64="--enable-kvm -monitor stdio \\
-M q35 -m 1G -smp 4 -cpu host \\
-cdrom Hyra.iso"
+KERN_CFLAGS="$KERN_CFLAGS_AMD64"
+
+if test "x$TARGET" = "xaarch64"
+then
+ KERN_CFLAGS="$KERN_CFLAGS_AARCH64"
+ BOOT_FW="BOOTAA64.EFI"
+fi
+
+
HYRA_BUILDDATE=`export LANG=en_US.UTF-8 ; date`
HYRA_BUILDBRANCH="`basename $PWD`"
AC_SUBST(HYRA_BUILDDATE, [$HYRA_BUILDDATE])
AC_SUBST(HYRA_BUILDBRANCH, [$HYRA_BUILDBRANCH])
-AC_SUBST(KERNEL_CFLAGS, [$KERN_CFLAGS_AMD64])
+AC_SUBST(KERNEL_CFLAGS, [$KERN_CFLAGS])
AC_SUBST(QEMU_FLAGS, [$QEMU_FLAGS_AMD64])
AC_SUBST(QEMU, [qemu-system-x86_64])
-AC_SUBST(ARCH, [amd64])
+AC_SUBST(BOOT_FW, [$BOOT_FW])
+AC_SUBST(ARCH, [$TARGET])
AC_SUBST(TOOLCHAIN, [clang])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT