aboutsummaryrefslogtreecommitdiff
path: root/lib/mlibc/tests/rtdl/scope3/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mlibc/tests/rtdl/scope3/meson.build')
-rw-r--r--lib/mlibc/tests/rtdl/scope3/meson.build9
1 files changed, 9 insertions, 0 deletions
diff --git a/lib/mlibc/tests/rtdl/scope3/meson.build b/lib/mlibc/tests/rtdl/scope3/meson.build
new file mode 100644
index 0000000..0c98583
--- /dev/null
+++ b/lib/mlibc/tests/rtdl/scope3/meson.build
@@ -0,0 +1,9 @@
+libfoo = shared_library('foo', 'libfoo.c')
+libbar = shared_library('bar', 'libbar.c', build_rpath: test_rpath, link_with: libfoo)
+libbaz = shared_library('baz', 'libbaz.c', build_rpath: test_rpath, link_with: libfoo)
+test_depends = [libfoo, libbar, libbaz]
+
+libfoo_native = shared_library('native-foo', 'libfoo.c', native: true)
+libbar_native = shared_library('native-bar', 'libbar.c', build_rpath: test_rpath, link_with: libfoo_native, native: true)
+libbaz_native = shared_library('native-baz', 'libbaz.c', build_rpath: test_rpath, link_with: libfoo_native, native: true)
+test_native_depends = [libfoo_native, libbar_native, libbaz_native]