summaryrefslogtreecommitdiff
path: root/lib/mlibc/tests/rtdl/preinit/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mlibc/tests/rtdl/preinit/meson.build')
-rw-r--r--lib/mlibc/tests/rtdl/preinit/meson.build18
1 files changed, 18 insertions, 0 deletions
diff --git a/lib/mlibc/tests/rtdl/preinit/meson.build b/lib/mlibc/tests/rtdl/preinit/meson.build
new file mode 100644
index 0000000..1a7f398
--- /dev/null
+++ b/lib/mlibc/tests/rtdl/preinit/meson.build
@@ -0,0 +1,18 @@
+if host_machine.cpu_family() == 'riscv64'
+ # gp isn't initialized until after crt1.o runs, so to access
+ # globals in our pre-initializers we must disable it.
+ test_additional_link_args = ['-Wl,--no-relax']
+endif
+
+libfoo = shared_library('foo', 'libfoo.c',
+ dependencies: libc_dep,
+ override_options: 'b_sanitize=none',
+ link_args: test_additional_link_args,
+)
+test_link_with = [libfoo]
+
+libfoo_native = shared_library('native-foo', 'libfoo.c',
+ link_args: ['-ldl'] + test_additional_link_args,
+ native: true
+)
+test_native_link_with = [libfoo_native]