aboutsummaryrefslogtreecommitdiff
path: root/lib/mlibc/sysdeps/dripos/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mlibc/sysdeps/dripos/meson.build')
-rw-r--r--lib/mlibc/sysdeps/dripos/meson.build71
1 files changed, 0 insertions, 71 deletions
diff --git a/lib/mlibc/sysdeps/dripos/meson.build b/lib/mlibc/sysdeps/dripos/meson.build
deleted file mode 100644
index afecf25..0000000
--- a/lib/mlibc/sysdeps/dripos/meson.build
+++ /dev/null
@@ -1,71 +0,0 @@
-
-rtdl_sources += files(
- 'generic/generic.cpp'
-)
-
-libc_sources += files(
- 'generic/entry.cpp',
- 'generic/generic.cpp',
- 'generic/thread.cpp',
- 'generic/thread_entry.S'
-)
-
-if not no_headers
- install_headers(
- 'include/abi-bits/auxv.h',
- 'include/abi-bits/seek-whence.h',
- 'include/abi-bits/vm-flags.h',
- 'include/abi-bits/errno.h',
- 'include/abi-bits/fcntl.h',
- 'include/abi-bits/in.h',
- 'include/abi-bits/resource.h',
- 'include/abi-bits/stat.h',
- 'include/abi-bits/signal.h',
- 'include/abi-bits/socket.h',
- 'include/abi-bits/termios.h',
- 'include/abi-bits/blkcnt_t.h',
- 'include/abi-bits/blksize_t.h',
- 'include/abi-bits/dev_t.h',
- 'include/abi-bits/gid_t.h',
- 'include/abi-bits/ino_t.h',
- 'include/abi-bits/mode_t.h',
- 'include/abi-bits/nlink_t.h',
- 'include/abi-bits/pid_t.h',
- 'include/abi-bits/uid_t.h',
- 'include/abi-bits/access.h',
- 'include/abi-bits/wait.h',
- 'include/abi-bits/limits.h',
- 'include/abi-bits/utsname.h',
- 'include/abi-bits/ptrace.h',
- 'include/abi-bits/poll.h',
- 'include/abi-bits/epoll.h',
- 'include/abi-bits/packet.h',
- 'include/abi-bits/inotify.h',
- 'include/abi-bits/clockid_t.h',
- 'include/abi-bits/shm.h',
- 'include/abi-bits/mqueue.h',
- 'include/abi-bits/suseconds_t.h',
- 'include/abi-bits/fsfilcnt_t.h',
- 'include/abi-bits/fsblkcnt_t.h',
- 'include/abi-bits/socklen_t.h',
- 'include/abi-bits/statfs.h',
- 'include/abi-bits/statvfs.h',
- 'include/abi-bits/ioctls.h',
- 'include/abi-bits/xattr.h',
- 'include/abi-bits/msg.h',
- subdir: 'abi-bits',
- follow_symlinks: true
- )
-endif
-
-if not headers_only
- crt = custom_target('crt1',
- build_by_default: true,
- command: c_compiler.cmd_array() + ['-c', '-o', '@OUTPUT@', '@INPUT@'],
- input: 'crt-x86_64/crt1.S',
- output: 'crt1.o',
- install: true,
- install_dir: get_option('libdir')
- )
-endif
-