aboutsummaryrefslogtreecommitdiff
path: root/lib/mlibc/options/crypt/meson.build
diff options
context:
space:
mode:
Diffstat (limited to 'lib/mlibc/options/crypt/meson.build')
-rw-r--r--lib/mlibc/options/crypt/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/mlibc/options/crypt/meson.build b/lib/mlibc/options/crypt/meson.build
new file mode 100644
index 0000000..a476f34
--- /dev/null
+++ b/lib/mlibc/options/crypt/meson.build
@@ -0,0 +1,13 @@
+if disable_crypt_option
+ subdir_done()
+endif
+
+libc_sources += files(
+ 'generic/crypt-stubs.cpp',
+)
+
+if not no_headers
+ install_headers(
+ 'include/crypt.h',
+ )
+endif