aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 0 insertions, 23 deletions
diff --git a/configure.ac b/configure.ac
index afe3e34..ec44f8c 100644
--- a/configure.ac
+++ b/configure.ac
@@ -16,29 +16,6 @@ QEMU_FLAGS_X86_64="--enable-kvm -monitor stdio \\
HYRA_BUILDDATE=`export LANG=en_US.UTF-8 ; date`
HYRA_BUILDBRANCH="`basename $PWD`"
-# Enable Spectre mitigation option
-AC_ARG_ENABLE([spectre-mitigation],
- [AS_HELP_STRING([--enable-spectre-mitigation], [Enable Spectre mitigation (IBRS or similar)])],,
- [enable_spectre_mitigation=$enableval])
-
-# Enable serial debug
-AC_ARG_ENABLE([serial-debug],
- [AS_HELP_STRING([--enable-serial-debug], [Allow serial debugging])],,
- [enable_serial_debug=$enableval])
-
-
-if test "x$enable_spectre_mitigation" = "xyes"; then
- AC_SUBST(SPECTRE_MITIGATION, [1])
-else
- AC_SUBST(SPECTRE_MITIGATION, [0])
-fi
-
-if test "x$enable_serial_debug" = "xyes"; then
- AC_SUBST(SERIAL_DEBUG, [1])
-else
- AC_SUBST(SERIAL_DEBUG, [0])
-fi
-
AC_SUBST(HYRA_BUILDDATE, [$HYRA_BUILDDATE])
AC_SUBST(HYRA_BUILDBRANCH, [$HYRA_BUILDBRANCH])