summaryrefslogtreecommitdiff
path: root/lib/mlibc/tests/rtdl/rtld_next/meson.build
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2024-03-07 17:28:00 -0500
committerIan Moffett <ian@osmora.org>2024-03-07 17:28:32 -0500
commitbd5969fc876a10b18613302db7087ef3c40f18e1 (patch)
tree7c2b8619afe902abf99570df2873fbdf40a4d1a1 /lib/mlibc/tests/rtdl/rtld_next/meson.build
parenta95b38b1b92b172e6cc4e8e56a88a30cc65907b0 (diff)
lib: Add mlibc
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'lib/mlibc/tests/rtdl/rtld_next/meson.build')
-rw-r--r--lib/mlibc/tests/rtdl/rtld_next/meson.build25
1 files changed, 25 insertions, 0 deletions
diff --git a/lib/mlibc/tests/rtdl/rtld_next/meson.build b/lib/mlibc/tests/rtdl/rtld_next/meson.build
new file mode 100644
index 0000000..d156c24
--- /dev/null
+++ b/lib/mlibc/tests/rtdl/rtld_next/meson.build
@@ -0,0 +1,25 @@
+# Prevent tail calls, as it breaks libc's 'calling object' detection.
+no_tail_calls = '-fno-optimize-sibling-calls'
+
+libfoo = shared_library('foo', 'libfoo.c',
+ dependencies: libc_dep,
+ c_args: no_tail_calls,
+)
+libbar = shared_library('bar', 'libbar.c',
+ dependencies: libc_dep,
+ c_args: no_tail_calls,
+)
+test_link_with = [libfoo, libbar] # foo is linked before bar
+
+libfoo_native = shared_library('native-foo', 'libfoo.c',
+ c_args: [no_tail_calls, '-D_GNU_SOURCE'],
+ link_args: '-ldl',
+ native: true
+)
+libbar_native = shared_library('native-bar', 'libbar.c',
+ c_args: [no_tail_calls, '-D_GNU_SOURCE'],
+ link_args: '-ldl',
+ native: true
+)
+test_native_link_with = [libfoo_native, libbar_native]
+