summaryrefslogtreecommitdiff
path: root/lib/mlibc/tests/rtdl/preinit/meson.build
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2024-03-07 17:28:52 -0500
committerIan Moffett <ian@osmora.org>2024-03-07 18:24:51 -0500
commitf5e48e94a2f4d4bbd6e5628c7f2afafc6dbcc459 (patch)
tree93b156621dc0303816b37f60ba88051b702d92f6 /lib/mlibc/tests/rtdl/preinit/meson.build
parentbd5969fc876a10b18613302db7087ef3c40f18e1 (diff)
build: Build mlibc + add distclean target
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'lib/mlibc/tests/rtdl/preinit/meson.build')
-rw-r--r--lib/mlibc/tests/rtdl/preinit/meson.build18
1 files changed, 0 insertions, 18 deletions
diff --git a/lib/mlibc/tests/rtdl/preinit/meson.build b/lib/mlibc/tests/rtdl/preinit/meson.build
deleted file mode 100644
index 1a7f398..0000000
--- a/lib/mlibc/tests/rtdl/preinit/meson.build
+++ /dev/null
@@ -1,18 +0,0 @@
-if host_machine.cpu_family() == 'riscv64'
- # gp isn't initialized until after crt1.o runs, so to access
- # globals in our pre-initializers we must disable it.
- test_additional_link_args = ['-Wl,--no-relax']
-endif
-
-libfoo = shared_library('foo', 'libfoo.c',
- dependencies: libc_dep,
- override_options: 'b_sanitize=none',
- link_args: test_additional_link_args,
-)
-test_link_with = [libfoo]
-
-libfoo_native = shared_library('native-foo', 'libfoo.c',
- link_args: ['-ldl'] + test_additional_link_args,
- native: true
-)
-test_native_link_with = [libfoo_native]