summaryrefslogtreecommitdiff
path: root/lib/mlibc/options/crypt/meson.build
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2024-03-07 17:28:00 -0500
committerIan Moffett <ian@osmora.org>2024-03-07 17:28:32 -0500
commitbd5969fc876a10b18613302db7087ef3c40f18e1 (patch)
tree7c2b8619afe902abf99570df2873fbdf40a4d1a1 /lib/mlibc/options/crypt/meson.build
parenta95b38b1b92b172e6cc4e8e56a88a30cc65907b0 (diff)
lib: Add mlibc
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'lib/mlibc/options/crypt/meson.build')
-rw-r--r--lib/mlibc/options/crypt/meson.build13
1 files changed, 13 insertions, 0 deletions
diff --git a/lib/mlibc/options/crypt/meson.build b/lib/mlibc/options/crypt/meson.build
new file mode 100644
index 0000000..a476f34
--- /dev/null
+++ b/lib/mlibc/options/crypt/meson.build
@@ -0,0 +1,13 @@
+if disable_crypt_option
+ subdir_done()
+endif
+
+libc_sources += files(
+ 'generic/crypt-stubs.cpp',
+)
+
+if not no_headers
+ install_headers(
+ 'include/crypt.h',
+ )
+endif