summaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2025-02-15 00:14:29 -0500
committerIan Moffett <ian@osmora.org>2025-02-15 00:14:29 -0500
commit0007887a0a0de22bcf781af5f2fc18b538e733f7 (patch)
tree43ee88e0c44e2d6c9ab797dc2080e0c75f6fd74f /configure.ac
parent0ef34f93d9da735bf5774222979552f417c4c44c (diff)
project: Hyra Release v1.3
What's new? - Add new defines in sys/cdefs.h. - Clean up Kernel synchronization API (sys/kern/kern_synch.c). - Added queue(3) and tree(3) to the man page directory. - Added extra security measures around interrupt entry. code to prevent potentially nasty speculative execution issues (see commit 817d1ad). - Default to Clang/LLVM during builds. - Significant console optimizations (see commit d8fd1be) - Significant boot latency reductions due to PCI bus scan optimizations (see commit e7cf7a9) Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 1 insertions, 1 deletions
diff --git a/configure.ac b/configure.ac
index 8a9db93..90fe705 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,4 +1,4 @@
-AC_INIT([Hyra], [1.2], [ian@osmora.org])
+AC_INIT([Hyra], [1.3], [ian@osmora.org])
KERN_CFLAGS_AMD64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector -fno-pic \\
-Werror=implicit -Werror=implicit-function-declaration \\