aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authornishi <nishi@vegaa.systems>2023-07-07 23:40:27 +0000
committernishi <nishi@vegaa.systems>2023-07-07 23:40:27 +0000
commitd963772c6633a0610898aaba2ae90d461e8f2de8 (patch)
tree64d9e0a7b09b205d5f42011aa2bfe88e321f706d /configure.ac
should be working, should be
git-svn-id: https://svn.vegaa.systems/svn/vega-Vega/trunk@7 a8a8aea2-181d-ee11-89e8-15fd0e089fc4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac23
1 files changed, 23 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..c44b3f0
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,23 @@
+# $Id$
+
+AC_INIT([Vega], [0.0.1], [ian@vegaa.systems])
+
+KERN_CFLAGS_X86_64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector -fno-pic \\
+ -Werror=implicit -Werror=implicit-function-declaration \\
+ -Werror=implicit-int -Werror=int-conversion \\
+ -Werror=missing-prototypes \\
+ -Werror=incompatible-pointer-types -Werror=int-to-pointer-cast \\
+ -Werror=return-type -Wunused -mabi=sysv -mno-80387 -mno-mmx -mno-3dnow \\
+ -mno-sse -mno-sse2 -mno-red-zone -mcmodel=kernel -pedantic \\
+ -I sys/include/ -I sys/include/lib/ -D_KERNEL -Wno-pointer-sign -MMD"
+
+QEMU_FLAGS_X86_64="--enable-kvm -monitor stdio \\
+ -M q35 -m 1G -smp 4 -cpu host \\
+ -cdrom Vega.iso"
+
+AC_SUBST(KERNEL_CFLAGS, [$KERN_CFLAGS_X86_64])
+AC_SUBST(QEMU_FLAGS, [$QEMU_FLAGS_X86_64])
+AC_SUBST(QEMU, [qemu-system-x86_64])
+AC_SUBST(ARCH, [amd64])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT