aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2025-05-02 12:19:38 -0400
committerIan Moffett <ian@osmora.org>2025-05-02 12:19:38 -0400
commita9545970af4c35e7135c8005a9a94e21ca19623c (patch)
tree044466b29d52de129be5ba5ab27d949239c70cf0 /configure.ac
parent788c45fcaba9e64d84a1a293217bb532259168c7 (diff)
build: Add @PROJECT_ROOT@ build var
Add project root build var as some hosts may not handle relative paths the same as others. Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac2
1 files changed, 2 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index 3729adb..79269c5 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1,6 +1,7 @@
AC_INIT([Hyra], [1.6], [ian@osmora.org])
TARGET="amd64"
+PROJECT_ROOT=`pwd`
BOOT_FW="BOOTX64.EFI"
AC_ARG_ENABLE([aarch64],
[AS_HELP_STRING([--enable-aarch64], [Enable AARCH64 Support])],
@@ -53,6 +54,7 @@ AC_SUBST(QEMU_FLAGS, [$QEMU_FLAGS_AMD64])
AC_SUBST(QEMU, [qemu-system-x86_64])
AC_SUBST(BOOT_FW, [$BOOT_FW])
AC_SUBST(ARCH, [$TARGET])
+AC_SUBST(PROJECT_ROOT, [$PROJECT_ROOT])
AC_SUBST(TOOLCHAIN, [clang])
AC_CONFIG_FILES([Makefile])
AC_OUTPUT