aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2024-06-04 13:41:11 -0400
committerIan Moffett <ian@osmora.org>2024-06-04 13:45:31 -0400
commit98ccb3a2d41015b42d46d8b382decc755a003c3f (patch)
tree4e514830880a4deabebb60c38055792695314ae6 /configure.ac
project: Initial commit
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac27
1 files changed, 27 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
new file mode 100644
index 0000000..43f517d
--- /dev/null
+++ b/configure.ac
@@ -0,0 +1,27 @@
+AC_INIT([Hyra], [0.1], [ian@osmora.org])
+
+KERN_CFLAGS_AMD64="-fexceptions --std=gnu11 -ffreestanding -fno-stack-protector -fno-pic \\
+ -Werror=implicit -Werror=implicit-function-declaration \\
+ -Werror=implicit-int -Werror=int-conversion \\
+ -Werror=missing-prototypes \\
+ -Werror=incompatible-pointer-types -Werror=int-to-pointer-cast \\
+ -Werror=return-type -Wunused -mabi=sysv -mno-80387 -mno-mmx -mno-3dnow \\
+ -mno-sse -mno-sse2 -mno-red-zone -mcmodel=kernel -pedantic \\
+ -I sys/include/ -I sys/include/lib/ -D_KERNEL -Wno-pointer-sign -MMD"
+
+QEMU_FLAGS_AMD64="--enable-kvm -monitor stdio \\
+ -M q35 -m 1G -smp 4 -cpu host \\
+ -cdrom Hyra.iso"
+
+HYRA_BUILDDATE=`export LANG=en_US.UTF-8 ; date`
+HYRA_BUILDBRANCH="`basename $PWD`"
+
+AC_SUBST(HYRA_BUILDDATE, [$HYRA_BUILDDATE])
+AC_SUBST(HYRA_BUILDBRANCH, [$HYRA_BUILDBRANCH])
+
+AC_SUBST(KERNEL_CFLAGS, [$KERN_CFLAGS_AMD64])
+AC_SUBST(QEMU_FLAGS, [$QEMU_FLAGS_AMD64])
+AC_SUBST(QEMU, [qemu-system-x86_64])
+AC_SUBST(ARCH, [amd64])
+AC_CONFIG_FILES([Makefile])
+AC_OUTPUT