aboutsummaryrefslogtreecommitdiff
path: root/configure.ac
diff options
context:
space:
mode:
authorIan Moffett <ian@osmora.org>2024-01-17 20:59:53 -0500
committerIan Moffett <ian@osmora.org>2024-01-17 20:59:53 -0500
commit469f601e210a74bb08408be894c9ec84701d6715 (patch)
tree41e8b517fceddbf581ac2333a82bb39f21899647 /configure.ac
parent09f3fd474c0175170c177cdcb372034eda86c70f (diff)
kernel: Add serial logging support
Signed-off-by: Ian Moffett <ian@osmora.org>
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac11
1 files changed, 11 insertions, 0 deletions
diff --git a/configure.ac b/configure.ac
index ffb2daf..afe3e34 100644
--- a/configure.ac
+++ b/configure.ac
@@ -21,6 +21,11 @@ AC_ARG_ENABLE([spectre-mitigation],
[AS_HELP_STRING([--enable-spectre-mitigation], [Enable Spectre mitigation (IBRS or similar)])],,
[enable_spectre_mitigation=$enableval])
+# Enable serial debug
+AC_ARG_ENABLE([serial-debug],
+ [AS_HELP_STRING([--enable-serial-debug], [Allow serial debugging])],,
+ [enable_serial_debug=$enableval])
+
if test "x$enable_spectre_mitigation" = "xyes"; then
AC_SUBST(SPECTRE_MITIGATION, [1])
@@ -28,6 +33,12 @@ else
AC_SUBST(SPECTRE_MITIGATION, [0])
fi
+if test "x$enable_serial_debug" = "xyes"; then
+ AC_SUBST(SERIAL_DEBUG, [1])
+else
+ AC_SUBST(SERIAL_DEBUG, [0])
+fi
+
AC_SUBST(HYRA_BUILDDATE, [$HYRA_BUILDDATE])
AC_SUBST(HYRA_BUILDBRANCH, [$HYRA_BUILDBRANCH])